poor graphics performance in Navisworks

I found a great post the other day from Beyond Design that I thought I should share.  This is from 2011 but if you are experiencing a sluggish Navisworks some of this may be helpful.  Specifically the part I am interested in is below but the whole article is here.

The Model

Is it detailed? Is it large? How many triangles, you can find out under Project > Scene Statistics, compare this to what your card can handle? Models with lots of curves require more triangles, just get a piping model and switch to hidden line mode; you’ll see that this can build up quickly to create thousands and millions of triangles that need to be drawn. If you reduce the faceting factor (Options > File Readers), when bringing the native CAD file in, then this will reduce the number of triangles we use to draw the rounded item, lower it too much though and the item may look blocky, the default is set to 1.

Are there any parts of the model a long way away? Do a quick audit of the model by seeing if Zoom All zooms so far out you can’t see the model you expected. Use the Selection Box tool to work out what is distant from the model and see if you can change in the native application, if not then Hide it.

If you have set lots of the model to be required (i.e. prioritized when you are navigating) then you may experience lots of drop out of all the other items. Again, start from nothing (right click > Reset All > Unrequire All) and slowly build up adding those essential items.

Try running the model with ‘Scene Lights’ Lighting and ‘Shaded’ Mode on the Viewpoints tab, if this significantly improves performance then you might have over done it on the materials and lighting. Look at using the materials and lighting you need rather than going overboard and adding materials and lights to everything.